Subscriptions Services - Unavailable
Incident Report for VideoAsk
Resolved
This incident has been resolved.
Posted Mar 16, 2023 - 14:04 CET
Identified
We have identified errors impacting our Subscriptions Services. Users trying to change their plans are impacted. We are working on a resolution with high priority.

We plan to provide an update in 20-30 minutes or as soon as it's available.
Posted Mar 16, 2023 - 13:49 CET
This incident affected: Subscriptions.